package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x)
#(?:cat)
(cat)\1`)
var str = `catcatcat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}