#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z]{1}0{7}|[A-Z]{2}0{6}|[A-Z]{3}0{5}|[A-Z]{4}0{4}|[A-Z]{5}0{3}|[A-Z]{6}0{2}|[A-Z]{7}0{1}|[A-Z]{8})([0-9]{8})([0-9a-z]{4})([1-9a-z]{1}[0-9a-z]{4}|0{1}[0-9a-z]{4}|0{2}[0-9a-z]{3}|0{3}[0-9a-z]{2}|0{4}[0-9a-z]{1})"
Local $sString = "YONHPX0020170607ed68000p2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")