$re = '/(?=(one|two|three|four|five|six|seven|eight|nine|ten))/m';
$str = 'eighthree';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);