re = /(?!^)"(?!$)/
str = '"Hello people " how are you doing " what are " you upto "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end