$re = '/^(?:[1-3][ab]|n)$/m';
$str = '1a
2a
3a
1b
2b
3b
n
MAMA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);