$re = '/start\s+"[^"\r\n]*"(*SKIP)(*F)|"[^"\r\n]*"/m';
$str = 'start "text" - doesn\'t match
123 "text" - match
"text" - match
But with cases like this it doesn\'t:
123 "text" 123 "text"
start "test " start " text"
start "test " start " text" start "test " start " text"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);