import re
regex = re.compile(r"^(?=[^()]{5,10}$)[^()]*(?:[()][^()]*){0,2}$", flags=re.MULTILINE)
test_str = ("234234\n"
"234234\n"
"2222()234\n"
"sdf(asd)df\n"
"234((2342\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")