#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^\/)\w{2}(-\w{2})?(?=\/)"
Local $sString = "/en/home.aspx" & @CRLF & _
"/en-gb/ts/tc/home.aspx" & @CRLF & _
"/en-gb/home.aspx" & @CRLF & _
"/en-de/home.aspx" & @CRLF & _
"/de-de/home.aspx" & @CRLF & _
"/en/home.aspx" & @CRLF & _
"/en-fb/afspfas.aspx" & @CRLF & _
"/en-gb/ts/ca/anotherPage.aspx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")