// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m){{\W*((?:(?:[a-zA-Z_]\w+?(?:\[\d+\])?(?:\.[a-zA-Z_])?))+)\W*}}").unwrap();
let string = "{{ users[0].name }}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}