re = /AnumeroSequencial=\d{7}/m
str = 'AJAXREQUEST=_viewRoot&fPP%3Aj_id139%3AnomeParte=&fPP%3Aj_id148%3AoutrosNomesAlcunha=&fPP%3Aj_id157%3AnomeAdvogado=&tipoMascaraDocumento=on&fPP%3AdpDec%3AdocumentoParte=&fPP%3AnumeroProcesso%3AnumeroSequencial=0001252&fPP%3AnumeroProcesso%3AnumeroDigitoVerificador=13&fPP%3AnumeroProcesso%3AAno=2021&fPP%3AnumeroProcesso%3AramoJustica=5&fPP%3AnumeroProcesso%3ArespectivoTribunal=07&fPP%3AnumeroProcesso%3ANumeroOrgaoJustica=8923&fPP%3AprocessoReferenciaDecoration%3AhabilitarMascaraProcessoReferencia=true&fPP%3AprocessoReferenciaDecoration%3AIdProcessoReferenciaComMascaraDecoration%3AIdProcessoReferenciaComMascara=&fPP%3Aj_id225%3Aassunto=&fPP%3Aj_id234%3AclasseJudicial=&fPP%3Aj_id243%3AnumeroDocumento=&fPP%3AdecorationDados%3AnumeroOAB=&fPP%3AdecorationDados%3AletraOAB=&fPP%3AdecorationDados%3AufOABCombo=org.jboss.seam.ui.NoSelectionConverter.noSelectionValue&fPP%3AjurisdicaoComboDecoration%3AjurisdicaoCombo=org.jboss.seam.ui.NoSelectionConverter.noSelectionValue&fPP%3AorgaoJulgadorComboDecoration%3AorgaoJulgadorCombo=org.jboss.seam.ui.NoSelectionConverter.noSelectionValue&fPP%3AdataAutuacaoDecoration%3AdataAutuacaoInicioInputDate=&fPP%3AdataAutuacaoDecoration%3AdataAutuacaoInicioInputCurrentDate=10%2F2022&fPP%3AdataAutuacaoDecoration%3AdataAutuacaoFimInputDate=&fPP%3AdataAutuacaoDecoration%3AdataAutuacaoFimInputCurrentDate=10%2F2022&fPP%3AvalorDaCausaDecoration%3AvalorCausaInicial=&fPP%3AvalorDaCausaDecoration%3AvalorCausaFinal=&fPP%3Aj_id384%3AmovimentacaoProcessualSuggest=&fPP%3Aj_id384%3Aj_id395_selection=&fPP=fPP&autoScroll=&javax.faces.ViewState=j_id3&fPP%3Aj_id402=fPP%3Aj_id402&AJAX%3AEVENTS_COUNT=1&'
subst = '1234569-19.2009.7.19.1009'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result