$re = '/LD_PRELOAD=(\S+)[\n\r]+^\s*export\s+LD_PRELOAD/m';
$str = '# Some comment
LD_PRELOAD=/usr/lib64/libstdc++.so.6
export LD_PRELOAD
# more comments';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);