package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+(?:\h+\S+)?)?(?:\h+(.+))?`)
var str = `
a
a b
a b c
a b c d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}