package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[=]{1,}[\s]{0,}[\w]+[\s]{0,}[=]{1,}`)
var str = `== Title1 ===`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}