import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((^|\\s)#(.*)$)|(^\\n)|(\\n(\\s|)+#(.*)$)|([\\n\\s]+#.*)|([\\n\\s]{2,}$)";
final String string = "#This RegEx removes inline comments and blank lines in python code!\n\n"
+ "# This will save you tokens and time when using GPT to help code and debug.\n\n\n"
+ "import requests\n"
+ "import os\n\n\n"
+ "#Define vars\n"
+ "def add(a, b):\n"
+ " return a + b\n"
+ "# print results\n"
+ "result = add(2, 3)\n"
+ "print(result) # Output: 5\n"
+ "print(\"Complete\")\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}