$re = '/^1[01]*(\.[01]*1)?$/m';
$str = '1.001100101
1.0000000000000010
1
0
0.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);