$re = '/^(\w+)\b.*\1$/m';
$str = 'world test world
world test worl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);