import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-\\s*([^\\r\\n-]*?)\\s*-\\s*([^\\r\\n-]*?)\\s*-\\s*Coord\\.";
final String string = "Fica outorgada, em nome da PREFEITURA MUNICIPAL DE\n"
+ "JUQUIÁ, CNPJ n. 46.585.964/0001-40, a autorização administrativa para interferência(s) em recursos hídricos superficiais, para\n"
+ "fins de rodoviário no município de JUQUIÁ, conforme abaixo\n"
+ "identificado:\n"
+ "- Travessia Aérea 01 - Afluente do Rio Juquiá - Coord.\n"
+ "Geográficas Latitude S 24° 19' 54,00\" - Longitude o 47° 38'\n"
+ "54,10\" - Prazo 30 anos.\n"
+ "- Travessia Aérea 02 - Afluente do Rio Juquiá - Coord.\n"
+ "Geográficas Latitude S 24° 19' 58,00\" - Longitude o 47° 38'\n"
+ "52,20\" - Prazo 30 anos.\n"
+ "- Travessia Aérea 03 - Afluente do Rio Juquiá - Coord.\n"
+ "Geográficas Latitude S 24° 19' 58,00\" - Longitude o 47° 38'\n"
+ "52,00\" - Prazo 30 anos.\n"
+ "- Travessia Aérea 04 - Afluente do Rio Juquiá - Coord.\n"
+ "Geográficas Latitude S 24° 19' 59,00\" - Longitude o 47° 38'\n"
+ "51,70\" - Prazo 30 anos.\n"
+ "- Travessia Aérea 05 - Afluente do Rio Juquiá - Coord.\n"
+ "Geográficas Latitude S 24° 19' 59,40\" - Longitude o 47° 38'\n"
+ "51,50\" - Prazo 30 anos.\n"
+ "- Travessia Aérea 06 - Afluente do Rio Juquiá - Coord.\n"
+ "Geográficas Latitude S 24° 19' 59,90\" - Longitude o 47° 38'\n"
+ "51,30\" - Prazo 30 anos. Processo DAEE 9502113 - Extrato de\n"
+ "Portaria 4063/19.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}