// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([LRD](?:\. )?[0-9]{3,6}-[0-9]{1,3}-?[0-9]{0,2})( à [LRD]?(\. )?[0-9]{3,6}-[0-9]{1,3}-?[0-9]{0,2})?").unwrap();
let string = " \"reponse\": \"<p>L'employeur peut procéder à des changements d’horaires dans l'entreprise sans obtenir l’accord préalable du comité d'entreprise si cette modification n'est que ponctuelle ou ne concerne qu'un salarié, et n'affecte pas les conditions générales de travail dans l'entreprise.\\nAinsi, si les horaires individualisés appliqués dans l'entreprise sont aménagés du lundi au vendredi, l'employeur peut aménager les horaires d'un salarié du mardi au samedi si celui-ci est affecté à des tâches d'entretien et de réparation dont certaines ne peuvent s'effectuer que le samedi : arrêt de la Cour de Cassation, chambre sociale, du 1er juill. 1997, n° 95-12.000, n° 2871 P + B.</p><p>Il peut, dans les mêmes conditions, modifier l’horaire initial, si cela ne change pas les horaires définis par votre contrat de travail ou ne modifie pas la durée du travail hebdomadaire ou le salaire.</p><p>En l’espèce, votre contrat de travail joint en copie à vos questions, prévoit bien que votre horaire peut être modifié afin de répondre à la charge de travail fluctuante sans que cela puisse être considéré comme une modification du contrat de travail, laquelle supposerait alors votre accord.</p><p>Si l’horaire est collectif, l’employeur doit l’afficher dans les lieux de travail où il s’applique, l’employeur établissant un décompte de la durée du travail, des repos compensateurs acquis et de leur prise effective, pour chacun des salariés concernés. Les délégués du personnel peuvent consulter ces documents : article L. 3171-2 du code du travail.</p><p>L’article suivant du même code indique aussi que l’employeur tient à la disposition de l’agent de contrôle de l’inspection du travail compétent pour l’entreprise, les documents permettant de comptabiliser le temps de travail accompli par chaque salarié. En cas d’horaire collectif, un double est transmis à l’inspecteur du travail avant l’affichage sur les lieux de travail : il en est de même en cas de modification de celui-ci : article D. 3171-3 et D. 3171-4 du code déjà cité.</p>\",
\"text\": \"En cas de licenciement pour inaptitude, le code du travail prévoit une indemnité spécifique due lorsque l'inaptitude a une origine professionnelle ( Accident du travail ou maladie professionnelle).Cette indemnité comprend (L1226-14 du code du travail) :l'indemnité compensatrice de préavis (L1234-5) : salaire jusqu'à expiration du préavis ( salaire et avantages) et indemnité compensatrice de congés payés.l'indemnité spécifique de licenciement (L1234-9) : somme correspondant au double de l'indemnité légale de licenciement.L'article 33 de la convention collective de la boulangerie prévoit par ailleurs une indemnité particulière en cas d'inaptitude pour les 55 ans et plus. Dans ce cas, avec les indemnités de licenciement perçues par ailleurs, le salarié se verra reverser une indemnité spécifique: le montant de cet ensemble devant être équivalent à l'indemnité de départ perçue en cas de départ à la retraite.\",
],
\"refs\": [
{
\"url\": \"https://www.legifrance.gouv.fr/affichCode.do?idSectionTA=LEGISCTA000006195925&cidTexte=LEGITEXT000006072050\",
\"source\": \"Code du travail : articles L. 6322-12 à 6322-13\",
\"sujet\": \"Acquisition des droits lors d'un Cif (L6322-13)\"
},
{
\"url\": \"https://www.legifrance.gouv.fr/affichCode.do?idSectionTA=LEGISCTA000033010756&cidTexte=LEGITEXT000006072050\",
\"source\": \"Code du travail : articles L2145-5 à L2145-13\",
\"sujet\": \"Acquisition des droits lors d'un congé de formation économique, sociale et syndicale (L2145-10)\"
},
{
\"url\": \"https://www.legifrance.gouv.fr/affichCode.do?idSectionTA=LEGISCTA000033004799&cidTexte=LEGITEXT000006072050\",
\"source\": \"Code du travail : articles L3142-54 à L3142-57\",
\"sujet\": \"Acquisition des droits lors d'un congé de formation d'un animateur ou cadre de jeunesse (L3142-55)\"
}
]
},
{
\"theme\": \"travail\",
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}