$re = '/^(?=.{6,12}$)(?:[^A-Z]*[A-Z]){2,4}[^A-Z]*$/m';
$str = 'Valid matches would be:
HamBurger
LeTtUce
TACOss
But invalid matches would be:
ABCDE1234
aBcDeFgHiJ
ADBC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);