const regex = new RegExp('(?<!\\d)\\d{1,2}([.:/ -])(?:\\d{1,2}|\\w{3,})\\1\\d{4}(?!\\d)', 'gm')
const str = ` 12-23-2019
29 10 2019
1:2:2018`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}