package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d+\.?\d+)\s?(.*)`)
var str = `12.34 picas
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}