$re = '/(\w)(\1+){3}/i';
$str = 'aaaa
rrrr
rupak
axway
rupakaaaaaxwayrrrr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);