const regex = /"(.+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(.+)"', 'gm')
const str = ` "Promo_End_Day__c": "2021-12-25",
"Promo_Start_Day__c": "2021-11-25",
"Additional Marketing Fee Rate": "100",
"Budget": "100000.00",
"Budget Period": "Weekly",
"Day(s) of Week": "M-F",
"Day Time Constraints": null,
"Days Until Expiry": null,
"Dining Spend Minimum": null,
"Discount Percentage for Consumer": null,
"Discounted Delivery Fee": null,
"Flat Discount Amount for Consumer": "7.00",
"Item Discount Percentage": null,
"Marketing_Flat_Fee__c": 7.00,
"Max Amount from Marketing Percent": null,
"Max Discount Amount for Consumer": null,
"Max Number of Redemptions": 2,
"Menu Item IDs/Option IDs - Items(s) in list A": null,
"Menu Item IDs/Option IDs - Items(s) in list B": null,
"Menu Item Minimum Quantity": null,
"Order_Cart_Minimum__c": 50.00,
"Offer Detailed Description": null,
"Offer Title": null,
"Order Service Type": "All",
"Promotion Code": null,
"Store_v_Business_Level_Targeting__c": null,
"Target Cx Audience": "All Users",
"Time of Day": "9-5 EST"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);