import re
regex = re.compile(r"\[.*\]\((https?:\/\/(?:www\.|(?!www))[^\s\.]+\.[^\s]{2,}|www\.[^\s]+\.[^\s]{2,})")
test_str = "Steps:\\n\\n[Step as , asdasd . sd32 'd](http://dev.nzfood-site.wn.bauer-media.net.au/silver-fern-farms-competition-21001) 1 Preheat oven to 120°C. Arrange six 1 1/2-cup ramekins in large baking dish lined [with](http://dev.nzfood-site.wn.bauer-media.net.au/silver-fern-farms-competition-21001) a cloth. \\nStep 2 In a medium saucepan, combine cream and vanilla. Place over medium heat and bring to almost boiling point. \\nStep 3 Meanwhile, in a bowl, whisk yolks and sugar together until thick and pale. Gradually pour in hot cream mixture, whisking constantly. \\nStep 4 Return mixture to clean saucepan. Cook on low heat 10-12 minutes, stirring constantly until thick enough to just coat the back of a wooden spoon (be careful not to overheat or mixture will curdle). \\nStep 5 Divide custard between ramekins. Pour boiling water into baking dish to come halfway up sides of ramekins. Bake 20-25 minutes until almost set and slightly wobbly in centre. Remove ramekins. \\nStep 6 Cool completely in fridge. Just before serving, sprinkle custards with an even layer of raw sugar. Using a kitchen blowtorch, drag the flame back and forth over the sugar until caramelised."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")