const regex = /^(?=(.{1,64}@.{1,255}))([-+%_a-zA-Z0-9]{1,64}(\.[-+%_a-zA-Z0-9][^.]{0,}){0,})@[^-\.@#!$&^*~`={}|'"?]([a-zA-Z0-9_]{1,63}(\.[a-zA-Z0-9-]{0,}){0,}[^.](?!.web)(\.[a-zA-Z]{2,6}){1,4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(.{1,64}@.{1,255}))([-+%_a-zA-Z0-9]{1,64}(\\.[-+%_a-zA-Z0-9][^.]{0,}){0,})@[^-\\.@#!$&^*~`={}|\'"?]([a-zA-Z0-9_]{1,63}(\\.[a-zA-Z0-9-]{0,}){0,}[^.](?!.web)(\\.[a-zA-Z]{2,6}){1,4})$', 'gm')
const str = `sample@mk.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}