$re = '/\d*(?<![\d])[\d]{1}(?=[.])/m';
$str = '1.2.1234
5.06.01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);