$re = '/\d$/m';
$str = 'Vinnie: 1
Piglet: 2
Heffalump: 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);