$re = '/^([2-3])\.([1-9])\.([1-9])/m';
$str = '3.2.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);