const regex = /^\s*(?<name>.+)\scompleted/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?<name>.+)\\scompleted', 'gm')
const str = ` Michael just did their 5th workout! This is an
automated notification.
Do not reply to this email.
Michael just did their 5th workout!
Michael Montefusco completed BFR On-Ramp Lower Extremity and rated it as
RPE 4 / 10 (easy). Michael set 3 new personal bests.
View in Mobile App
<https://mandrillapp.com/track/click/30003805/www.trainerize.com?p=eyJzIjoiTEFqSE1tZDFTMXlBd09ldUc1RlVQNDZaVS1BIiwidiI6MSwicCI6IntcInVcIjozMDAwMzgwNSxcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvd3d3LnRyYWluZXJpemUuY29tXFxcL29wZW5BcHAuYXNweD9ncm91cElEPTE1NDg1MiZhY3Rpb249b3Blbk1zZ1wiLFwiaWRcIjpcImYzMWVmYWU1NjdmMDRhNThiNTVjOTEzNGE1ZDA0Yzg0XCIsXCJ1cmxfaWRzXCI6W1wiMmViMmE1ZTMzNDI0MDMzYTVhYWQ1MmVhMTY5NDFiNDgwYzczMDBmZlwiXX0ifQ>
View in Web App
<https://mandrillapp.com/track/click/30003805/smartcuffsacademy.trainerize.com?p=eyJzIjoiZnJSQjFyd21YT2d1b19ZcVU3aWJHRFg3aGtnIiwidiI6MSwicCI6IntcInVcIjozMDAwMzgwNSxcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvc21hcnRjdWZmc2FjYWRlbXkudHJhaW5lcml6ZS5jb21cXFwvYXBwXFxcL1wiLFwiaWRcIjpcImYzMWVmYWU1NjdmMDRhNThiNTVjOTEzNGE1ZDA0Yzg0XCIsXCJ1cmxfaWRzXCI6W1wiMmViMmE1ZTMzNDI0MDMzYTVhYWQ1MmVhMTY5NDFiNDgwYzczMDBmZlwiXX0ifQ>
Download the iOS
<https://mandrillapp.com/track/click/30003805/www.trainerize.com?p=eyJzIjoianRsQ3VIM2x3UThJQWV1bkdmVHNoZGdFM3RVIiwidiI6MSwicCI6IntcInVcIjozMDAwMzgwNSxcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvd3d3LnRyYWluZXJpemUuY29tXFxcL29wZW5BcHAuYXNweD9ncm91cElEPTE1NDg1MiZtb2RlPWRvd25sb2FkSU9TXCIsXCJpZFwiOlwiZjMxZWZhZTU2N2YwNGE1OGI1NWM5MTM0YTVkMDRjODRcIixcInVybF9pZHNcIjpbXCIyZWIyYTVlMzM0MjQwMzNhNWFhZDUyZWExNjk0MWI0ODBjNzMwMGZmXCJdfSJ9>
or
Android
<https://mandrillapp.com/track/click/30003805/www.trainerize.com?p=eyJzIjoiTWh6eE1WWGN0Y0hQQXRSOEM3dDY0a1F5T2prIiwidiI6MSwicCI6IntcInVcIjozMDAwMzgwNSxcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvd3d3LnRyYWluZXJpemUuY29tXFxcL29wZW5BcHAuYXNweD9ncm91cElEPTE1NDg1MiZtb2RlPWRvd25sb2FkQW5kcm9pZFwiLFwiaWRcIjpcImYzMWVmYWU1NjdmMDRhNThiNTVjOTEzNGE1ZDA0Yzg0XCIsXCJ1cmxfaWRzXCI6W1wiMmViMmE1ZTMzNDI0MDMzYTVhYWQ1MmVhMTY5NDFiNDgwYzczMDBmZlwiXX0ifQ>
app. To receive this message in-app, via mail, or both, change your
notification settings through the mobile app.
Turn off email notifications
<https://mandrillapp.com/track/click/30003805/smartcuffsacademy.trainerize.com?p=eyJzIjoiY1dIOEwtb1QtT2g1Y2dtNnFsZFpsZjZSRU1FIiwidiI6MSwicCI6IntcInVcIjozMDAwMzgwNSxcInZcIjoxLFwidXJsXCI6XCJodHRwczpcXFwvXFxcL3NtYXJ0Y3VmZnNhY2FkZW15LnRyYWluZXJpemUuY29tXFxcL2FwcFxcXC9wdWJsaWNcXFwvdW5zdWJzY3JpYmUuYXNweD90b2tlbj1TVEEwVVhwQmVVZHdlVEU1Vml0UFpsWTVaSE5uU1hsclFtZzBOR1p5Y0U0MSZ0eXBlPTBcIixcImlkXCI6XCJmMzFlZmFlNTY3ZjA0YTU4YjU1YzkxMzRhNWQwNGM4NFwiLFwidXJsX2lkc1wiOltcImMzZWM1NzVjMGFkM2M3YTk1NWMyYjFlMDg3ZDdmMTVkNjg1NmM0NDlcIl19In0>
for new messages
Powered by Trainerize
<https://mandrillapp.com/track/click/30003805/www.trainerize.com?p=eyJzIjoiQU1pY2h4VjJpTmd6ampXSXFrT1E5N3VDMmtZIiwidiI6MSwicCI6IntcInVcIjozMDAwMzgwNSxcInZcIjoxLFwidXJsXCI6XCJodHRwOlxcXC9cXFwvd3d3LnRyYWluZXJpemUuY29tXFxcL1wiLFwiaWRcIjpcImYzMWVmYWU1NjdmMDRhNThiNTVjOTEzNGE1ZDA0Yzg0XCIsXCJ1cmxfaWRzXCI6W1wiYjU4NTgyYWJmYTM0NzQwNDliN2Q4ZDU2YzU1YjhmMWE2MWUwNzcwOVwiXX0ifQ>
*Copyright © 2020 Trainerize, All rights reserved.*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}