using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(aves|rep)\b";
string input = @"Penguin AVES
Caiman REP
Komodo.Rep
Blue Jay.aves
Peregrine aves Falcon
Iguana+rep
Rep Salamander";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}