re = /(?<=\/)[^\/]+(?=\.[^\/]+$)/m
str = 'https://res-3.cloudinary.com/ngxcoder/image/upload/f_auto,q_auto/v1/blog-images/5oonz9.jpg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end