#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)BCF-(\d+)\s+([\w]+)[A-Z\s\d\-]+(?:BTS-\d+[\sA-Z-]+\d+\s+\d+\s+)([A-Z]+)"
Local $sString = "BCF-1522 FLEXI EDGE U WO 4 B1522 WO" & @CRLF & _
" 01137 22186 BTS-1522 U WO 1 0" & @CRLF & _
" CALLEORIN6 RF/-" & @CRLF & _
" 23" & @CRLF & _
" TRX-001 U WO 673 0 1787 MBCCH P 10" & @CRLF & _
" TRX-002 U WO 681 0 1787 9" & @CRLF & _
" TRX-003 U WO 663 0 1787 8" & @CRLF & _
" TRX-004 U WO 659 0 1787 6" & @CRLF & _
" 01137 22187 BTS-1523 U WO 0 1" & @CRLF & _
" CALLEORIN7 RF/-" & @CRLF & _
" 24" & @CRLF & _
" TRX-005 U WO 675 0 320 MBCCH P 8" & @CRLF & _
" TRX-006 U WO 657 0 320 10" & @CRLF & _
" TRX-007 U WO 665 0 320 4" & @CRLF & _
" TRX-008 U WO 638 0 320 0" & @CRLF & _
" 01137 22188 BTS-1524 U WO 0 0" & @CRLF & _
" CALLEORIN8 RF/-" & @CRLF & _
" 16" & @CRLF & _
" TRX-009 U WO 651 0 1729 MBCCH P 7" & @CRLF & _
" TRX-010 U WO 643 0 1729 4" & @CRLF & _
" TRX-011 U WO 648 0 1729 7" & @CRLF & _
"" & @CRLF & _
"BCF-1526 ULTRASITE U BL-BCF 7 B1526 WO" & @CRLF & _
" 01134 01186 BTS-1526 U BL-BCF 0 0" & @CRLF & _
" LDANIELAS6 RF/-" & @CRLF & _
" 0" & @CRLF & _
" EDGE TRX-001 U BL-BCF 672 0 1736 MBCCH P 2" & @CRLF & _
" EDGE TRX-002 U BL-BCF 674 0 1736 0" & @CRLF & _
" EDGE TRX-003 U BL-BCF 657 0 1737 5" & @CRLF & _
" EDGE TRX-004 U BL-BCF 648 0 1737 6" & @CRLF & _
" 01134 01187 BTS-1527 U BL-BCF 0 0" & @CRLF & _
" LDANIELAS7 RF/-" & @CRLF & _
" 0" & @CRLF & _
" EDGE TRX-005 U BL-BCF 645 0 1736 2" & @CRLF & _
" EDGE TRX-006 U BL-BCF 639 0 1736 0" & @CRLF & _
" EDGE TRX-007 U BL-BCF 683 0 1736 MBCCH P 5" & @CRLF & _
" EDGE TRX-008 U BL-BCF 641 0 1736 6" & @CRLF & _
" 01134 01188 BTS-1528 U BL-BCF 0 0" & @CRLF & _
" LDANIELAS8 RF/-" & @CRLF & _
" 0" & @CRLF & _
" EDGE TRX-009 U BL-BCF 662 0 1737 MBCCH P 7" & @CRLF & _
" EDGE TRX-010 U BL-BCF 643 0 1737 2" & @CRLF & _
" EDGE TRX-011 U BL-BCF 652 0 1737 0" & @CRLF & _
" EDGE TRX-012 U BL-BCF 664 0 1737 5" & @CRLF & _
"" & @CRLF & _
"BCF-1540 ULTRASITE L BL-USR 3 B1540 BL" & @CRLF & _
" 01134 12543 BTS-0055 L BL-USR 0 0" & @CRLF & _
" SANTAINES3 RF/-" & @CRLF & _
" 0" & @CRLF & _
" EDGE TRX-001 U BL-USR 128 0 1773 MBCCH P 9" & @CRLF & _
" EDGE TRX-003 U BL-USR 145 0 1773 10" & @CRLF & _
" EDGE TRX-004 U BL-USR 237 0 1773 4" & @CRLF & _
" EDGE TRX-005 U BL-USR 155 0 1773 2" & @CRLF & _
" EDGE TRX-006 U BL-USR 233 0 1773 9" & @CRLF & _
" EDGE TRX-007 U BL-USR 150 0 1773 10" & @CRLF & _
" 01134 12548 BTS-0057 L BL-USR 0 0" & @CRLF & _
" SANTAINES8 RF/-" & @CRLF & _
" 0" & @CRLF & _
" EDGE TRX-008 U BL-USR 669 0 1361 MBCCH P 6" & @CRLF & _
" EDGE TRX-010 U BL-USR 643 0 1361 4" & @CRLF & _
" EDGE TRX-011 U BL-USR 683 0 1361 2" & @CRLF & _
" EDGE TRX-012 U BL-USR 664 0 1361 9" & @CRLF & _
"" & @CRLF & _
"BCF-1543 ULTRASITE U WO 6 B1543 WO" & @CRLF & _
" 01137 12822 BTS-0206 U WO 0 0" & @CRLF & _
" VERACRUZ2 RF/-" & @CRLF & _
" 0" & @CRLF & _
" EDGE TRX-001 U WO 137 0 1771 MBCCH P 10" & @CRLF & _
" EDGE TRX-002 U BL-RSL 128 0 1771 8" & @CRLF & _
" EDGE TRX-003 U WO 139 0 1771 10" & @CRLF & _
" 01137 12828 BTS-0717 U WO 1 0" & @CRLF & _
" VERACRUZ8 RF/-" & @CRLF & _
" 8" & @CRLF & _
" EDGE TRX-005 U WO 678 0 1735 MBCCH P 0" & @CRLF & _
" EDGE TRX-007 U BL-RSL 655 0 1735 3" & @CRLF & _
" EDGE TRX-008 U WO 649 0 1735 6" & @CRLF & _
" EDGE TRX-009 U BL-RSL 657 0 1735 3" & @CRLF & _
"" & @CRLF & _
"BCF-1615 ULTRASITE U WO 2 B1615 WO" & @CRLF & _
" 01139 10012 BTS-0086 L BL-USR 0 0" & @CRLF & _
" ADRIATICA2 RF/-" & @CRLF & _
" 0" & @CRLF & _
" EDGE TRX-001 U BL-USR 135 0 1366 MBCCH P 10" & @CRLF & _
" EDGE TRX-003 U BL-USR 133 0 1366 10" & @CRLF & _
" EDGE TRX-004 U BL-USR 147 0 1366 9" & @CRLF & _
" EDGE TRX-005 U BL-USR 153 0 1682 10" & @CRLF & _
" EDGE TRX-006 U BL-USR 155 0 1682 4" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")