#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\* )(@\$[a-z]|@\\?[a-zA-Z])"
Local $sString = "/**" & @CRLF & _
" * @param string $someParam comment" & @CRLF & _
" * @param $otherParam comment" & @CRLF & _
" */" & @CRLF & _
"@function();" & @CRLF & _
"@\function();" & @CRLF & _
" @$this->output();" & @CRLF & _
" @self::output();" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")