import re
regex = re.compile(r"(([0-9][,]?[])([0-9][?=\ ]?[В]?[Вт]))", flags=re.MULTILINE)
test_str = ("SMD 0603 49,9 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF\n"
"SMD 0603 49,9 Ом ± 1% 0,1Вт CR0603-FX-49R9ELF\n\n"
"SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX\n"
"SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")