# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"orderId\":\"(?<orderId>[^\"]+)\"},\"error\":\{\"errorCode\":\"(?<errorCode>[^\"]+)\""
test_str = "message: Send jms message [queue=SEP.TO.PEIN, statusCode=200, idempotencyId=b95d0d10-9709-4299-9d3e-8c65dd5a539d, processId=PE2400000582026, delivApp=null, message={\"transactionItems\":[{\"itemId\":\"4f2170cd-35f6-4d03-b0fe-6ebbca6e00cb\",\"status\":\"FAILED\",\"accountIdentification\":{\"contractAccountNumber\":{\"branchCode\":\"0784\",\"accountNumber\":\"0190595009\",\"currencyCode\":\"INR\"}}},{\"itemId\":\"adea3dff-8e02-433e-a2ad-94bac828989b\",\"status\":\"FAILED\",\"accountIdentification\":{\"contractAccountNumber\":{\"branchCode\":\"0784\",\"accountNumber\":\"0190595009\",\"currencyCode\":\"INR\"}}},{\"itemId\":\"bf96b534-2150-4228-843f-9fb920a1f44f\",\"status\":\"FAILED\",\"accountIdentification\":{\"contractAccountNumber\":{\"branchCode\":\"0784\",\"accountNumber\":\"0190595009\",\"currencyCode\":\"INR\"}}},{\"itemId\":\"cb6e42ac-ee83-48b6-8213-7faf0311c6d0\",\"status\":\"FAILED\",\"accountIdentification\":{\"contractAccountNumber\":{\"branchCode\":\"0784\",\"accountNumber\":\"0190595009\",\"currencyCode\":\"INR\"}}},{\"itemId\":\"bdd8a76f-ddb4-4616-a793-68ddd72aad0e\",\"status\":\"FAILED\",\"accountIdentification\":{\"contractAccountNumber\":{\"branchCode\":\"0784\",\"accountNumber\":\"0190595009\",\"currencyCode\":\"INR\"}}},{\"itemId\":\"cb339f2a-ad85-410c-9043-275aa1e4fe17\",\"status\":\"FAILED\",\"accountIdentification\":{\"contractAccountNumber\":{\"branchCode\":\"0784\",\"accountNumber\":\"0190595011\",\"currencyCode\":\"INR\"}}}],\"orderStatusResponse\":{\"orderStatus\":\"ORDER_FAILURE\",\"orderId\":\"b95d0d10-9709-4299-9d3e-8c65dd5a539d\"},\"error\":{\"errorCode\":\"SEP013\",\"errorDescription\":\"Cannot find IDMS-0784 account by accNumber: 0190595009\"}}]"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.