import re
regex = re.compile(r"(.)\B", flags=re.MULTILINE)
test_str = "133114"
subst = "$1,"
result = regex.sub(subst, test_str)
if result:
print(result)