$re = '/^Groups:.*?\s990\b/m';
$str = 'Groups: 990 991 992
Groups: 991 990 992
Groups: 991 992 990';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);