$re = '/\d+\s-\s(.*)/m';
$str = '1 - Automatik
18 - In Betrieb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);