$re = '/jobs\/([^\/]+\/?){1,2}$/m';
$str = 'website.com/jobs/value1/value2/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);