#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?(exp)(?P<exp>)\btest\b|(?P<fruits>)\bpie\b)"
Local $sString = "test pie sdfds " & @CRLF & _
"test dsf sdfs" & @CRLF & _
"test sdfsdfsd pie" & @CRLF & _
"dfsdf test" & @CRLF & _
"dfsdfs test sdfsdf pie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")