$re = '/(?=.*[a-zA-Z0-9])^[a-zA-Z0-9~!@#$&*(),;:\'\-_]*$/m';
$str = 'a
123
^
!@!@!@!@
ac)(*&123
ac)(*&1^23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);