re = /(^[EeKkGgDdSsPpHh]\d{8}$)|(^(([Ee][a-fA-F])|([DdSsPp][Ee])|([Kk][Jj])|([Mm][Aa])|(1[45]))\d{7}$)/
str = '0341-86091234'
# Print the match result
str.match(re) do |match|
puts match.to_s
end