$re = '/^[^>]+>([^<]+)/m';
$str = '<a href="somelink;ref=start" class="head-title">APRILIA Tuono V4 1100 Factory, 175 PS</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);