$re = '/[A-Z]{2}-[0-9]{6}/m';
$str = 'BG-123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);