re = /<(a|p|b)>.*?<\/\1>/
str = '<b>Ключ <br> 1:</b>Значение 1<br><b>Ключ 2:</b>Значение 2<br><b>Ключ 3:</b>Значение 3<br><b>Ключ 4:</b>Значение 4<br>
<b>Ключ <br> 1:</b>Значение 1<br>
<b>Ключ 2:</b>Значение 2<br>
<b>Ключ 3:</b>Значение 3<br>
<b>Ключ 4:</b>Значение 4<br>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end