package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/?([a-zA-Z0-9_\-+]+)\/?$`)
var str = `edit
/edit
/edit/
/content/edit
/content/edit/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}