$re = '/(?!^1000$)^[1-9]\d{3,}$/m';
$str = '1000
1001
5023
10000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);