$re = '/^(?=.*\d)(?=.*[a-zA-Z])(?=.*\W).{6,30}$/';
$str = 'dji8bs&jk9ks
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);