import re
regex = re.compile(r"^0*([1-9]\d{2,}|[5-9]\d)$", flags=re.MULTILINE)
test_str = ("00000001231343543\n\n"
"0678\n\n"
"000000000 657567\n"
" 000657 76\n"
"00678")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")