$re = '/^\+268\d{9}$/m';
$str = '+268123456789
+26812345678933
268123456789
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);